Welcome to UK Christmas Lights. This is a forum for discussing Christmas lighting, Halloween lighting and more. We discuss both static and animated Christmas light displays, and cater for those who string up a single strand each year to the people who spend the whole year producing a jaw-dropping light show!

Setting up the Raspberry Pi & FPP to use both Wireless AND Ethernet with E682

Do you use another type of controller to the ones listed above?
If many people use it, we will create a dedicated thread.
User avatar
Raabaman
Posts: 39
Joined: Mon Jan 25, 2016 11:47 am
Location: Kingsclere
Display Type: Animated

Setting up the Raspberry Pi & FPP to use both Wireless AND Ethernet with E682

Postby Raabaman » Thu Mar 24, 2016 6:24 pm

I decided a little while ago that it would be best for my specific setup if I could have the show network separated from my home network in order to minimise the network traffic that might arise. I have also been intending to use my Raspberry Pi, with FPP, to run the actual show. Finally, I wanted to be able to have access to my E682 controller without having to connect to it directly. I wanted the RPi to be remote and accessed via my house wifi network and the controller to be connected by cable via the Ethernet port on the RPi. This meant I would need to use the RPi as a sort of network bridge.

I didn’t know how to do this.

After looking through numerous forum postings and other articles off the web I’ve finally gotten my RPi set up to run the controller on one subnet and allow access from my home network on a separate subnet. It’s not so complicated when you know the some of the basics, which I didn’t apparently.

Here’s a really long and probably confusing explanation of how I worked it out. It’s a living document so discussion will lead to updates.

***
What you need:
RPi – set up with FPP
Wireless dongle for RPi
Network cable
Available port to your home network (could be your laptop or router or switch)

To start you need to have access to the controller. In my case it’s a SanDevices E682. It comes default to IP address 192.168.1.206. My home network is the same subnet (192.168.1.***) so I just plugged it in to an open port on my network switch and it connects without issue. (if your network is on a different subnet you can find tons of info on switching your local IP subnet temporarily in order to get connected to your controller)

In a browser type in the controller address http://192.168.1.206/ hit enter and you will see the controller webpage. Change the IP address to a different subnet than your home network. In my case I set it to 192.168.100.206 . Hit the “Update System Info” button and you will now lose contact with your controller until the RPi & FPP are set up.

IP’s so far:
Home: 192.168.1.*** (whatever your network assigned to you)
E682: 192.168.100.206 (the address you picked, which has a different subnet than the home network)

Follow the instructions from Falcon Christmas to install FPP on your RPi.( http://falconchristmas.com/forum/index.php?board=8.0) Your IP address will vary depending on how you’ve started it up. Again, I plugged it in to an open port on my network switch and it was given an IP that would put it on the same subnet as my home network. If you’ve followed the instructions carefully you will be able to access FPP by going to http://fpp/ in your web browser. If you aren’t having luck with that then, like I had to do, plug the RPi into a monitor and just see what IP gets assigned to the RPi when the boot sequence scrolls past. Alternatively, you can also plug in a speaker or headphones to the audio jack on the RPi and it should read the IP address out.

***

Once connected to FPP you need to configure the network interface for both wireless and Ethernet port.

FPP => Status/Control => Network

There are 2 interface options here; eth0 & wlan0. Again, I chose wlan0 as my main network interface (home network) and eth0 as the “show network” where my controllers will connect.

As I had some trouble opening FPP using the default address above I found setting a static IP worked very well. You can find the Gateway and Netmask settings using a cmd tool in Windows:
Start => search => cmd
Right click on "cmd.exe" and select "Run as administrator"
In the window that now appears type: ipconfig
This will show you the basic settings for your local network.

You can now set the following in FPP
Interface Settings
Interface Name: wlan0
Interface Mode: Static
IP Address: 192.168.1.252
Netmask: 255.255.255.0
Gateway: 192.168.1.254

Wireless Settings:
WPA SSID: [your wifi network name]
WPA Pre Shared key (PSK): [your wifi network password]

Click “Update Interface”

Back to Interface Settings
Interface Name: eth0
Interface Mode: Static
IP Address: 192.168.100.66 [subnet value must be the same as used by controller. Eg 192.168.100.***]
[this IP is not actually accessible, it just gives an address to the Ethernet port]
Netmask: 255.255.255.0
Gateway: [no Gateway value as not accessing internet, etc]

Click “Update Interface”

DNS Settings
Host Name: FPP
DNS Server Mode: Manual
DNS Server 1: 192.168.1.254 {same as Gateway]
DNS Server 2:

Click “Update DNS”


TICK THIS BOX: Enable Routing between network interfaces

***

All done with the RPi and FPP setup. Turn off RPi, disconnect it form the network, wait a short while then restart.

In Windows, using that same “cmd” window from above, you now need to set a static route between the two separate network subnets.

Eg: 192.168.1.*** --> (I see you) --> 192.168.100.***

This is done using the “route” command. In my case it was this:

route ADD 192.168.100.0 MASK 255.255.255.0 192.168.1.252

The last IP address is the static address I gave the FPP on my home network. The command is telling the computer that 192.168.1.252 is the router for the 192.168.100.0 domain using the same netmask as shown in ipconfig.


Access FPP using the static address that you set above (wlan0: 192.168.1.252).

Access your controller using the static address that you set above (wlan0: 192.168.100.206).

*******

**Notes**

**The address you assign to the RPi Ethernet port eth0 (in my case 192.168.1.66) is not really an addressable location. It’s just the value for that specific, physical port that allows network traffic a path through. This network path allows access to the addressable location of your controller.

**You will only have access to the RPi through the PC that you set the static route up with. You can add the static route to other PC’s if you have need for more than one. The “-p” option in the route command will make the route persistent on your system, meaning you won’t have to type it in each time. However, I’m running Windows 10 and it stayed persistent without that switch.??

**You CAN access FPP with your mobile to run tests and start/stop the show!

**You can’t access the controller with your mobile.
Attachments
FPP-physical.jpg
FPP-physical.jpg (290.33 KiB) Viewed 1301 times
FPP-wlan0.jpg
FPP-wlan0.jpg (229.38 KiB) Viewed 1313 times
FPP-eth0.jpg
FPP-eth0.jpg (219.28 KiB) Viewed 1313 times